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1. Introduction 

1.1 Overview 

This whitepaper outlines how to perform live backups of your Exchange Server‟s information store database. For 

information on backing up individual mailboxes of an Exchange Server see our Exchange Mailbox Add-on 

whitepaper: www.backupassist.com/downloads/whitepapers/ExchangeMailboxBackup_WP.pdf  

1.2 Requirements 

To back up and restore your Exchange Server information store using BackupAssist you need the following: 

 BackupAssist v6 

 Windows 2000, XP, Server 2003, Server 2008 or Server 2008R2. 

 Microsoft Exchange Server 2000, 2003, 2007, or 2010 

 Windows Backup (NTBackup) or Volume Shadow Copy (VSS): 

NTBackup of Exchange server 

 
Win 2000 Win XP Win 2003 Win 2008 Win 2008R2 

Exchange 2000 
     

Exchange 2003 
     

Exchange 2007 
     

Exchange 2010 
     

VSS backup of Exchange 2003, 2007, 2010 

File replication 
     

Rsync 
     

Zip 
     

Windows imaging 
     

1.3 Local and remote backups of Exchange  

 
BackupAssist running on  

Server 2008 
BackupAssist running on  

Server 2003 

Local Exchange 

information store 

backup 
 

 
Using the NTBackup engine 

(Exchange 2000, 2003 and 2007) 

Remote Exchange 

information store 

backup 

 
To back up the Exchange information store of a remote server 

you need to install BackupAssist locally on the Exchange Server 

itself and purchase a separate BackupAssist license. 

 
Using the NTBackup engine 

(Exchange 2000, 2003 and 2007
1
). 

Local Exchange 

mailbox  backup 
2
 

2
 

Remote Exchange 

mailbox backup 
2
 

2
 

                                                           
1
 Refer to the Remote Exchange 2007 requirements section for more information.  

2
 Requires an Exchange Mailbox Add-on license. Refer to our Exchange Mailbox Whitepaper for more information. 

http://www.backupassist.com/downloads/whitepapers/ExchangeMailboxBackup_WP.pdf
http://www.backupassist.com/downloads/whitepapers/ExchangeMailboxBackup_WP.pdf
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1.3.1 Remote Exchange 2007 backup requirements 

If you are attempting to back up an Exchange 2007 Server remotely (i.e. Exchange 2007 is running on a different 

server than your backup server) you will need to install the Exchange Server Management Tools on the machine 

where BackupAssist is installed, which should be a machine running Windows 2000, XP or 2003. NTBackup will 

be used to back up the remote Exchange information store.  

Note: this method cannot be used to back up Exchange 2010 remotely. 

1. If BackupAssist is running on a 32-bit operating system: 

Download and install the Exchange Server 2007 Management Tools (32-bit): 

http://www.microsoft.com/downloads/details.aspx?familyid=6BE38633-7248-4532-929B-

76E9C677E802&displaylang=en  

2. If BackupAssist is running on a 64-bit operating system: 

Install the Exchange Server 2007 Management Tools (64-bit) from the installation disc or setup file used 

to install Exchange 2007 on your remote server. 

If you have installed a version of Exchange Server 2007 that came pre-packaged with Exchange 2007 Service 

Pack 1, you will need to make a small alteration to the Windows registry due to a change made by Microsoft.  

Note: if you installed Service Pack 1 after installing Exchange Server 2007 the change should not be required. 

Excerpt from Microsoft article:  

To adhere to the Microsoft Secure by Default initiative, the remote streaming functionality (server-wide) 

in Exchange 2007 SP1 is disabled by default. A manual override in the form of the following registry 

value must be enabled to restore this functionality: 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem  

Name: Enable Remote Streaming Backup 

Type: DWORD 

Value: 0 = default behavior (remote backup disabled); 1 = remote backup enabled 

Refer to http://technet.microsoft.com/en-us/library/aa998870.aspx for full instructions. 

2. Backing up Exchange using NTBackup 

2.1 Creating a NTBackup job 

If you are running BackupAssist on a Windows 2000, XP, or 2003 machine and need to back up Exchange 

Server either locally or remotely, complete the following steps to create a backup job. If you already have an 

NTBackup job you can skip to section 2.2. 

1. Launch BackupAssist and from the File menu select New backup job.  

2. Choose NTBackup and click Next.  

3. Continue configuring the job according to your requirements. You will need to configure Exchange backup 

after you have finished creating the job.  This is described in section 2.2. 

4. If you do not need to select data in the Files and folders step, click Next and then Ignore when 

prompted.  

http://www.microsoft.com/downloads/details.aspx?familyid=6BE38633-7248-4532-929B-76E9C677E802&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=6BE38633-7248-4532-929B-76E9C677E802&displaylang=en
http://technet.microsoft.com/en-us/library/aa998870.aspx
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5. Once you have created your backup job you will be taken to the job edit window:  
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2.2 Adding an Exchange Server to your backup selections 

To back up the information store using NTBackup you must add it to the Exchange Servers Window.  Once 

added, there are two types of Exchange Server backup you can configure: 

 Information store: entire Exchange Server database  

 Individual mailbox: brick-level backup of user mailboxes (requires the Exchange Mailbox Add-on). For 

details on mailbox backups refer to the Exchange Mailbox Add-on white paper. 

To add an Exchange Server to your job: 

1. From the left menu under Job settings select Exchange Servers. 

2. Within the Exchange Server selection section click Add Exchange Server. A window will appear that 

displays all of the available Exchange Servers on the network. 

 

Note: If your Exchange Server resides on a different domain to that of the machine where BackupAssist 

is installed you can enter the name or IP address of the Exchange Server and click Search. 

3. Click Add to add the selected Exchange Servers to your backup selections.  

4. Check Backup storage groups for each Exchange Server you want to back up. 

5. Now select which storage groups to back up for each Exchange Server:  

o Check Select all storage groups if you wish to back up all storage groups and any future storage 

groups that are created (recommended). You can exclude specific storage groups if required by 

unchecking them, but all future storage groups created will still be backed up.  

o Or, leave Select all storage groups unchecked and individually check each storage group to 

back up. No storage groups created in the future will be backed up, only those selected. 

6. Click Apply changes when you have finished making your selections. 

3. Restoring Exchange using NTBackup 

Restoring an Exchange Server from a backup created using NTBackup requires three steps. This example 

follows from the backup process completed during section 2. This example assumes that Exchange Server is 

installed on the system. If you backed up Exchange Server using a VSS application backup refer to section 6 for 

the required restoration steps. 

http://www.backupassist.com/downloads/whitepapers/ExchangeBackupAndRestore_WP.pdf
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Step 1: Dismounting Exchange Server stores 

Before you can restore your Exchange Server database you need to dismount the stores you are restoring to: 

1. Launch the Exchange System Manager from the Start menu. 

2. Expand the Servers tree to locate the appropriate server and storage group (screenshot below).  

3. Right-click each store individually (typically Mailbox Store and Public Folder Store) and select 

Dismount Store: 

 

4. Your stores should have an icon with a red arrow to indicate that they have been dismounted: 

 

Step 2: Performing the Exchange restore using NTBackup 

Run Windows Backup (NTBackup) to restore your Exchange Server database: 

1. Go to Start Menu > All Programs > Accessories > System Tools > Backup 

2. If Windows Backup launches in Wizard Mode click the Advanced Mode link 
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3. [Optional – remote restore]: If you are restoring to a remote Exchange Server click the Backup tab and 

then select Tools > Remote store from the top menu and enter the name of your remote Exchange Server. 

4. Now click the Restore and manage media tab. 

5. Locate the backup file or tape you wish to restore from and expand this tree until you locate the Exchange 

Server Information Store. If the backup required is not listed click Tools > Catalog backup file to locate 

the appropriate backup. 

6. Select each storage group you wish to restore: 

 

7. Click Start Restore. You will be prompted with several choices: 

 

o In this example we are restoring to a local Exchange Server so the Restore To field has been 

filled with the computer name of the local machine. 

o The Temporary location for log and patch files should be any directory with enough free space 

to perform the restore. Windows Backup will create the directory if it does not already exist. 

o If you are restoring a full backup of Exchange ensure that the last two options are checked. If you 

are restoring an incremental or differential backup, you should refer to the section 8 for help. 

8. Click OK to begin the restore of your Exchange Server. 

Step 3: Checking the restore logs 

Once the restore is complete, you should see the following window Restore Progress window: 
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Click Report to view the logs, which will show the results of the Exchange Server restore operation: 

 

If the logs do not indicate any errors, we recommended that you now reboot your server. Your Exchange 

information store should be restored, mounted and operational. 

4. Backing up Exchange using VSS 

4.1 Creating a VSS application backup job 

If you are running Exchange Server locally on the same machine where BackupAssist is installed, and are using 

an operating system with Volume Shadow Copy present (Windows XP/2003 and later), complete the following to 

back up your Exchange Server information store: 

1. Launch BackupAssist and from the File menu select New backup job.  

2. Select Windows Imaging
3
, File Replication, Zip, or Rsync and click Next.  

3. During the Files and Folders step select the Exchange Server and any other VSS applications that you 

want to back up: 

Note: locally installed VSS applications will be automatically detected and listed for selection. In some 

cases only applications that are currently running will be detected. If an application is not listed in the 

Files and Folders tab, try re-starting it and then click the Refresh button in BackupAssist. 

Imaging jobs (Server 2008 and REV / rdx / NAS jobs on Server 2008R2) 

For Imaging jobs running on Windows Server 2008 or jobs backing up to a REV or rdx drive or a NAS 

device on Windows Server 2008 R2, VSS applications can be selected from the Applications tab, but 

are backed up as part of a full volume snapshot. Volumes containing a VSS application that you want to 

back up must be fully selected. If you choose a VSS application to back up, the volumes that must be 

included for backup are listed in red. You can click the Select required volumes button if a required 

volume is not in your selections. 

 

                                                           
3 This is not available in Windows XP or 2003 
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File Replication, Zip and Imaging
4
 jobs 

You can select either entire VSS applications to back up or choose individual components: 

 

4. If you are editing an existing job, navigate to Volume selection from the left menu for a Windows Imaging 

job on Server 2008 and Files and folders from the left menu for any other job: 

  

5. Running a backup of your Exchange Server 

To test your Exchange Server backup you can either run your backup job manually or wait for the next scheduled 

backup to occur. 

When an Imaging, File Replication, Rsync or Zip job runs, BackupAssist will automatically perform a consistency 

check on your Exchange Server and truncate log files to correctly back up the Exchange information store. If, 

however, the VSS backup mode is set to „Copy‟ in the open files tab of a File Replication, Rsync, or Zip job, the 

Exchange logs will not be truncated. 

For NTBackup jobs BackupAssist backs up your Exchange Server during the second phase of the backup 

process, after the selected data files and system state (both optional) have been backed up. (This helps to 

eliminate an issue with Windows Backup (NTBackup) where a backup of both the system state and Exchange 

Server information store in the same pass fails.) 

To run a backup of your Exchange Server manually: 

1. Click Quick actions from the top menu of BackupAssist and select Run now. 

2. Choose Run a future backup and click Run. 

3. During the backup process you can view the job‟s progress in the Monitor window: 

                                                           
4
 Imaging jobs running on Windows Server 2008R2 only (excludes jobs backing up to REV / rdx drives) 
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5.1 Examining your backup logs 

Once the backup completes, you should examine the backup report to make sure your Exchange Server was 

backed up successfully: 

1. Click Reports in main navigation bar of BackupAssist. 

2. Double-click the latest report in the list and scroll down to the Exchange Server backup report section. 

For NTBackup jobs the report will include the backup and verify status of each storage group selected: 

 

For VSS application backup jobs the report will include an Exchange Database Consistency Check 

report and a VSS application backup report: 
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The Exchange System Manager will also indicate when the last full backup occurred on Exchange: 
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6. Restoring Exchange from a VSS application backup 

If you backed up your Exchange Server using VSS, as outlined in section 3 of this document, you can use the 

BackupAssist Restore Console to perform a VSS application restore of your entire Exchange Server:  

1. In BackupAssist, click Restore in the top navigation bar and choose BackupAssist Restore Console. 

2. The Restore Console will launch and you will be prompted with the 'Load backups' screen. 

3. Click Load all known backups to load all backup catalogues located in the BackupAssist settings 

folder. Alternatively, use the Browse option to locate the backup set from which you want to restore. 

4. Choose the job that corresponds to the backup from which you want to restore your Exchange Server 

from the available drop-down menu. 

5. Use the calendar to select the date of the backup from which you want to restore. 

6. Use the middle pane to expand the loaded backup set and select the Microsoft Exchange for restore.  

 

7. Click the Restore to button located on the bottom right of the window and follow the remaining prompts 

to your restore your Exchange Server. 

How the VSS application restore works 

VSS is designed to support live application restore. This means that you do not need to stop your 

Exchange Server before recovering a previous version of it from a backup.   
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If any Windows services need to be stopped and restarted during an application restore this will 

happen automatically. For example, during the restore of an Exchange database, the Exchange 

Server will prevent client access to that database. So while we recommend that you notify all users to 

stop using any applications before commencing a VSS application restore, the restore process will not 

be affected if the Exchange Server is in use. 

7. Restoring mailboxes via a Recovery Storage group 

The following process is useful if you have not setup mailbox backups to PST using the BackupAssist Exchange 

Mailbox Add-on and only want to recover one or more mailboxes rather than the entire Exchange Server. 

7.1 Perquisites for recovery process 

To restore Exchange 2007 or Exchange 2010 mailboxes from a full drive image backup created using the 

Windows Imaging engine in BackupAssist: 

1. Complete the restore operation on a machine running Windows Server 2008 and Server 2008R2. 

(Windows Vista and Windows 7 only provide support for drive volume restore.)  

2. Log into the machine as a user that is a member of the Backup Operators or Administrators group, or 

one that has been delegated the appropriate authority. 

3. Ensure the following registry key contains the string value highlighted below: 

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WindowsServerBackup\Application Support\ 

String information 

String name: Application Identifier 

Data: Exchange 

7.2 Performing a recovery of your Exchange Server from an Image backup 

After you have met the above prerequisites follow these steps to restore Exchange to a recovery storage group: 

1. Launch BackupAssist and click Restore in the navigation bar. 

2. Click Imaging engine restore to launch the Windows Server Backup console. 

3. Click Recover under the Actions pane.  

http://www.backupassist.com/downloads/whitepapers/ExchangeMailboxBackup_WP.pdf
http://www.backupassist.com/downloads/whitepapers/ExchangeMailboxBackup_WP.pdf


WHITEPAPER 
Exchange Server Backup and Restore 15 

 

© Cortex I.T. 2001-2010 

 

 

4. Once the Recovery Wizard has launched, select “This server”, and then click Next. 

 

5. Select the date from the calendar and the time from the drop-down list of the backup from which you 

want to restore. If you are recovering from this computer and the backup you select is stored on a 

removable media drive, you will be prompted to insert the relevant media.  Then click Next.  

6. When asked what you would like to recover, choose the option for Applications, and click Next.  

7. Under Applications, highlight „Exchange‟, and then click Next. 

 

8. Under Recovery destination, select Recover to another location, select a directory located on the 

Exchange server, then click Next. 

9. Review the details, and click Recover to restore the Exchange databases to the chosen directory.   

6.3 Creating and populating the Recovery storage group. 

1. Once the recovery process has completed navigate to the directory containing the backup of your 

storage group. You will need to rename all of the files in this directory beginning with an „E‟ to begin with 

„R‟. This includes all of your log files. 
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Initially you will have: 

 

After the renaming you would have: 

 

 

2. You will now need to create a Recovery Storage Group to mount the database you are restoring. Begin 

by launching your Exchange Management Console and opening the Disaster recovery toolbox from 

the Toolbox node in the Exchange tree. 

 

3. When the Disaster recovery toolbox loads, you will need to specify your server‟s name in order to 

connect to it. Enter the required details and click Next. 

4. You can now make a Recovery Storage group by clicking Create Recovery storage group.  

5. Once the wizard begins, select the storage group to restore to the RSG, and choose Next. 
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6. It is recommended that you use the default settings for the creation of the recovery storage group for 

ease of recovery. Make a note of the Recovery database path as you will need it in a few minutes. Once 

you have done this click Create recovery storage group and complete the wizard. 

7. Once you have completed the wizard, launch an explorer window and navigate to the Recovery 

database path. Copy the renamed files from step 1 into this folder. 

8. After copying the renamed database files go back to the Disaster recovery toolbox and click Mount or 

dismount databases in the Recovery storage group. Select the newly created RSG and mount it. 

6.4 Performing merge from your Recovery storage group. 

1. Once the RSG has mounted click Merge or copy mailbox contents. 

 

2. Ensure the correct mailbox is listed in the recovery storage group and click Gather merge information. 

3. Double check the merge details then click Perform pre-merge tasks. 

4. Select the mailboxes you wish to merge and then choose Perform merge actions. 

5. Check the merge results to verify that all tasks were successful and click Go back to task centre. 

Do not forget to remove the Recovery storage group after you have finished using it. This can be done by using 

the Remove the recovery storage group option from within the disaster recovery toolbox. 

7. Additional Resources 

Microsoft Technet has some detailed article on Exchange. For more information visit these sites
5
: 

Resource Web Address 

Exchange 2003 Disaster Recovery http://technet.microsoft.com/en-us/library/bb125070.aspx  

Exchange 2003 Administration Guide http://www.microsoft.com/downloads/details.aspx?FamilyId=98E454

81-1458-4809-97D6-50D8AEEBD8A1&displaylang=en  

Exchange Server Resources http://technet.microsoft.com/en-us/exchange/default.aspx  
 

                                                           
5
 BackupAssist disclaims any responsibility for the content or accuracy of these articles. 

http://technet.microsoft.com/en-us/library/bb125070.aspx
http://www.microsoft.com/downloads/details.aspx?FamilyId=98E45481-1458-4809-97D6-50D8AEEBD8A1&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=98E45481-1458-4809-97D6-50D8AEEBD8A1&displaylang=en
http://technet.microsoft.com/en-us/exchange/default.aspx

