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1.Exchange GranularRestore overview

The Exchange Granular Restore (EGR) console allows you to restore mail items usingirect Exchange
Injection. The backups used can be created bySystem Protection File Protectionor File Archiving This
means the backup you use to protect your Exchange Server caralso be used to restore mail items.

Exchange Granular Restore is the recommended tool for re storing mail items for Exchange 2013, 2010 and
2007. It is enabled in BackupAssist when you purchase theExchange GranularRestoreAdd-on and supersedes
the Exchange Mailbox Protectiorsolution. This earlier technology was purchased as theExchange MailboxAdd-
on, and is now bundled with the Exchange GranulaiRestoreAdd-on. Both solutions are supported.

Exchange add-on comparison

Feature

Exchange Mailbox Add -on

Exchange Granular Restore
Add-on

Exchange version support 2007, 2010 2007, 2010,2013
Exchange Server authentication Required Not required
Special backup type Required Not required
Mail Preview (before restore) No Yes

Backup size

Requires additional PST file backup

Part of Exchange Server backup

Backup destination

Local disks only

As supported by backup type

EGR support for backup types -

by server version

File Protection & File Archiving

Backups Windows 2008 Windows 2012
System Protection \% \%
\Y \%

The Exchange Granular Restore Add-on can restore:

Folders
File attachments
Contacts

= =4 4 -8 -

Mailboxes, mail folders and emails (cannot be encrypted)

Notes, Tasks Journal itemsand appointments

Journals, emails attachedin other emails and embedded email objects are currently not supported.

Requirements

1 BackupAssist 72 or later must be installed on the Exchange Server.

1 Operating systems: Windows Server 2012R2, 2008/R2.
1 RAM: 2561024 MB, depends on mail store size andOS version
1 May require free space on disk 1.5x the size of maildata being processed.

Exchange Granular Restore is tested for optimal performance up to the following dataset sizes.

1 Database size: 500 Gb / Mailbox size: 100 Gb
1 Number of messages in one maibox - 100,000, in the database- 2,000,000.
1 Number of mailboxes in the database: 2,000

© Cortex I.T. 2001-2015
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2.Backup considerations

Backup user identity

Backup jobs require an administrator account with read access to the data source, and full readwrite
access t o tdéstnatibnalcikrecpnimended that a dedicated backup account is created for
this purpose. T & are eatered ausing thé Backubauseridehtityoption on the Settings
tab, and your backup jobs will be launched using these credentials.

Exchange VM Detection

If your backup job contains a Hyper-V guest with an Exchange Server, the authentication information
for that guest should be entered into the Exchange VM Detection tab on the Selection screen when
you create the backup job. With these credentials, BackupAssist can detect what guests have an
Exchange Server, and list the EDB fikeavailable for each guest when you perform a restore using the
Exchange Granular Restore console

What do vou want to back up?

Selections
| Files and Applications | | Exchange ¥M Detection @

Authentication account for Hyper- quests running Exchange
If wour backup job contains & Hyper-¥ guest with an Exchange Server, the authentication
information For the guest should be entered below, With these credentials, Backupissist can detect

what quests have an Exchange Server, and list the EDE files avaikble For each quest when you
perform a restore using the Exchange Granular Restore console,

Username:

Password:

This password should never expire.

Diarnain:

Test

Figure 1: Figure 1: Selection screen - for an Exchange Server on a Hyper -V guest

The Exchange VM Detection tab will appear when the HyperV role is installed and running on the
server. If you are backing up multiple Exchange guests, each one should have the same username and
password.

The HyperV process is automated but the restore requires both the Exchange Granular Restore Add
on and the HyperV Granular Restore Addon licenses.

Restorevs. Recovery

A restore is the process of accessing a backup and restoring it to the original (or a new) locaton, if
your data is lost, corrupted or if you want an earlier version of that data. However, if your computer
cannot start itself, you may need to perform a recovery.

A recovery is the process by which a computer is recovered after hardware has been replaed or an
operating system failure has occurred, and your computer can no longer start itself. To perform a
recovery you need a bootable media to start your computer, and an image backup that the bootable
media can use to recover your operating system, dataand applications.

For more information on data recovery, see the Recover tab & RecoverAssist Whitepaper.

Exchange Granular Restore
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3.Creating an Exchange backup

This section explainshow to back up your ExchangeServer using BackupAssist on Windows
f ’ Server 2008, SBS 2008 and later operating systemsThese backups are used byExchange
u Granular Restoreto restore emails and individual mail items.

@ How to use Exchange Granular Restore is documented in Section 3,

'ﬁ' To backup Exchange on a Hyper -V guest for EGR, review the Exchange VM Detection section

Launch BackupAssist and follow the steps outlined below:

1. Select the Backup tab, and click Create a new backup Job
2. Select System Protection , File Protection or File Archiving .

If this is the first time you have created a backup job, you will be asked to provide a Backup user
identity if one has not been defined. See the BackupAssist settings whitepaper for guidance.

The following instructions use System Protectionto explain the Exchange VSS back up process.

£ Home i= Manage EX Monitor [] Reports

& Create a new backup job
@ Select the type of backup job you would like to create

Backup l:ﬂ System Protection

for Bare Metal recovery to an old or a new system

Method: Drive Imaging
Backup to Disk [ iSCSIf NAS

D File Protection B Exchange Mailbox Protectior

for historical versioning of files farrestore of email and publicfalders
Method: File Replication Method: Export to PST
Backup to Disk [ iSCSIf NAS [ Rsync Backup to Disk

@ Requires additional license

@ File Archiving % SQL Server Protection

for keeping long-term archives far near continuous database protection

Method: ZIPG4 Method: SQL Backup
Backup to Disk [ iSCSIf NAS [ Tape [ Blu-ray / ... Backup to Disk
B Requires additional license

Figure 2: New backup job & backup type selection screen

Instructions specific to each backup type, can be found in their respective whitepapers.

Remember: It is important to maintain both daily and archive (historical) backups as pat of your backup
strategy. To | earn more, see the Bscoekuing tab whitepaperds

Exchange Granular Restore
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3.

Selections: The selections screen is used to select the dataand applications that you would like to
back up. Any local Exchange Servergletected will be displayed here as application containers.

IﬁAn Exchange VM Detectiontab will be available if you are backing up an Exchange VM guest.

You can select an entire VSS application or choose individual components. To back up your
Exchange Server, selecthe Microsoft Exchange container.

If your local Exchange Servelis not listed in the Selectionsscreen, try restarting Exchange and the
VSS serviceand then click the Refreshbutton in BackupAssist.

£ Home i= Manage 4 Monitor [] Reports
7~ J) System Protection Wizard
&kj What do you want to back up?
Backup Selections

O i. Back up the Entire Systermn (Recommended)

@Hu Back Lp selected items only

e Refresh [ | Check selections E[ Estimate size O Key

El a r Critical volumes (tick For Bare Metal Recovery) Name | Type | Slzel Last Mnchﬂedl
; [F'% Local Disk () 2 Microsoft Exchange Server
|l Data and Backup Yolumes
§4 Share Paint Services
3 5al server
A Micrasaft Exchange - €
=[] Microsoft Exchangs Server - i)
2% 1 Microsoft Information Store

‘j Third Storage Group

4 |

0 Sorme volurne(s ) have been selected to ensure backup of yvour Application Selections.

< Back ][ Next > ][ LCancel

Figure 3: New backup job & Exchange Server VSS selection

1 For System Protection backups, \6S applicationswill be backed up as part of a Backup up the
Entire §/stem selection. In the example above,Back up selected iters only, was chosen and the
Exchange Server application containerwas selected.

1 For File Protection, Fle Archiving and System Protection backups, the top level Microsoft
Exchangeand Exctange Serverapplication containers should be selected.
Destination media: The destination screen is used to select the type of media that you want to

back your dataup to. Thisstepd s na me wi thé media tgpe gekected, avhen you click next.

Selecta device for your backup destination, and click Next.

Schedule: This screen is used to select when and how you would like the backup job to run, and
how long you would like the backup to be retained for. A selection of pre -configured schedules,
called schemes, will be displayed. Select an appropriate scheme, and clickNext .

To learn more about backup schedules,refer to the Backup managementsection below.

For detailed information on scheduling options and customizations, see the Backup tab user guide.

Exchange Granular Restore
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6. Setup destinatio n: This screen is used to onfigure the location of the media selected in step 4.

Configure your backup destination, and dick Next .

7. Notification s: Once a backup job has completed, BackupAssist can send an email to inform
selected recipients of the result. This email notification can be enabled during the creation of a
backup job, if the mail server has been configured.

To send email notifications, you will need to configure an SMTP mail server for BackupAssist.See
the Backup tab user guide for more information .

To enable email notifications:
a. Select,Add an email report notification.
b. Enter recipients into the Send reports to this email address field.

c. Enter recipients into the Also send reports to this email address field. You can then select
the condition under which the email should be sent, using the drop-down box.

8. Prepare media: If you selected a portable media device as your backup destination (such as an
external HDD or a RDX drive) youwill be given the option to prepare the media for BackupAssist.
BackupAssist will write a label orto the media so that it can recognise what media has been
attached, and determine if it is the correct media for your backup schedule.

To enable media detection:

a. Select,Let BackupAssist keep track of your media

b. Select what you would like BackupAssist todo, if the wrong media is inserted

c. Select what you would like BackupAssist to do,if new or unrecognized media is inserted

BackupAssist will display all removable media that are currently attached, along with a text field
and drive designation drop -down box, which can be used to provide a label for the media.

To prepare your media:
d. Enter the name and drive designation to be used for each media device listed.

e. SelectPrepare for each media device listed.

BackupAssist will now write the label to the media so that it is able to recognize the media and
ensure that the correct media is being used on the correct day. For example, if you put an RDX
drive in on Tuesday but it was labeled Wednesday, BackupAssist will warn you that the incorrect
media has beendetected.

9. Name your backup: Provide a name for your backup job, and click Finish.

U Your Exchange Server (VSS) backup job has now been created.

Important: Once a backup job has been created, it should be reviewed and run using the Manage
menu. This menu provides additional options to configure your backup.

Important : Once the backup has been created, it should be checked. You can check the backup by
performing a manual test restore, or using the Backup Verification feature. A manual restore is the only
way to fully test a backup, and regular manual restores should be part of your backup solution.

Note : To enable the Exchange 2007 VSS writer, please refer to thiblog article.

Exchange Granular Restore
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4.Exchange GranularRestore

Restore Add-on. This restore-based solution allows you to use System Protection File

g Exchange Granular Restore(EGR)is enabled with the purchase of the Exchange Granular
Protection and File Archivingbackups to restore individual mail items.

© Important considerations:

1 When you restore individual emails or a mailbox, the word RESTOREDVill appear in the Subject
line of every email. Thisis enabled by default and can be turned off using the EGR Options menu,
by selecting Options > Add RESTORERo exported item > No .

T BackupAssistds restore Home page casginsilé Hypdr-dy back.L
guests so that mail items can be restored using the Exchange Granular Restore console The
Hyper-V process is automated but the restore requires both the Exchange Granular Restore Adan
and the HyperV Granular Restore Adeon licenses

1 If you launch the EGR console from the Tools menu,you will need to manually mount the Data
container to locate an EDB file inside it. To mount a data container, please refer to our blog article.

To restore individual mai | items, follow the steps below

Step 1- Locate the Exchange backup

a) Start BackupAssist and select the Restore tab

The Restoretab has aHome page and a Toolsmenu. The Home page is the default screen and the
recommended starting point for performing a restore. The Tools menu should only be used by
experienced administrators or users being assisted by technical suport.

b) From the Restore Home page, select Exchange

4« Home ¥ Tools

@ Restore data files and applications

Select what you would like to restore

DI Files & Folders

Restore
Hyper-V g Exchange

oy 1
— SQL = Applications
S

Windows SystemState /
Volumes . :
Active Directory

@ Learn more about Restore >

Figure 4: Restore tab - Home page

This will open the Restore > Exchangescreen and display the restoreoptions available.

Exchange Granular Restore
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c) From the Restore > Exchange screen,select Exchange Granular Restore (.edb)

X Toals Eiea
[§ Restore »Exchange

e Exchange Server Restore
=]

Restore an entire Exchange Server or individual Storage Group(s) - for Exchange 2013, 2010, 2007, 2003

Restore Exchange Granular ' Mailbox Protection
_| Restore (.edb) n Restore (.pst)

Restore individual mail items or entire Restore individual mail items from Exchange
mailboxes from any standard Backup - for Mailbox Protection backups - for Exchange
Exchange 2013, 2010, 2007 2010, 2007, 2003

Figure 5: Restore Exchange page - selection screen
Backups made with BackupAssist 7.1 and laterthat contain Exchange databaseswill be displayed.

d) Selectthe database file to restore from

1 The backups disphyed can be filtered using the time period tabs.
1 Selecting a backup will expandits contents and display each .edb database inside the backup.

When you select the required database file, the Exchange GranularRestore console will start and
open the .edb file. A progress window will appear while the database is opening.

Backup Help 7

'« Home ¥ Tools

@ ... Exchange » Exchange Granular Restore (.edb)

4 Local Storage Groups 1 backup(s)

Last 7 days I Last 30 days | il Custom I

Show backups between p1josfzo1s x| and prjosfeoz x|

@ Jab Diate/Time Media
D File Protection - Exchange Server backup 21J05/2013 10:00 PM [ cehkesty

C:\Program Files\Microsoft\Exchange ServeriMailbox\Second Storage GroupiPublic Folder Database.edb

Restore

| C:\Program Files\MicrosoftiExchange ServeriMailbox\Second Storage Groupiriky . edb

Figure 6: Exchange Restore - backup and database selection

Once the .edb file has been opened, you will be able to view the mail items inside it.

Note : If you open Exchange Granular Restore from the Restore > Tools menu, you can use EGR tobrowse
to, an open, a PST or OSTile. You can then search the PST or OST file, and restore the selected mail items.

Exchange Granular Restore
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Step 2 - Locate the mail items

The Exchange Granular RestorédEGR)console has aBrowse mailtree and a Search fieldto help locate,
preview and select the mail items that you want to restore.

If you open EGRfrom the Restore > Tools menu, you can open a database using theOpen Exchange DButton.

Console options
Both the Browseand Searchfunctions can use the following options .

91 Display filter : Press CTL+F and a Filter field will appeaunder the list of currently displayed mail
items. Selectthe Subject From, To, Attachments, Createdor All filter, and enter the text to filter by.

1 Restore Deleted items : Display hidden deleted items is available in the Options menu, and
selecting it will give access to previously deleted mail items. This is not mail from the delete items
folder but mail items that are no longer pr esent. The database will reload when a selection is made
and the deleted items will and have a flag to indicate that they are a deleted item.

Deleted items from Exchange Server 2007 are stored in their original folders

Deleted items from Exchange 2010 and 2013 are stored in the folder Deletions. These items
cannot be restored to live Exchange Server database. It is recommendedhat these items are
exported to a PSTfile and then import ed into the live Exchange Server.

A
A

1 Display time: SelectDisplay time, from the Options menu and select Local or GMT. This applies to
the date in the properties tab of a mail item. The database will reload when the format is changed.

Using Browse

The Browse mailtreei s di spl ayed i mané. Brewsingdan theoitbnes §aa wdntetd réstore
is ideal when you know their location.

File Options Help

Exchange Granular Restore

Foe king [~]] ;@
[ Browse | Destination
[ ]4j Maibox Data edb Type  Sublect Sigtus  From To Mfochm... | Created Mo Exchange server
-[C159 /o=MoSuchEmail/ou=Exchange Adminis attached
7159 Mex Clark [mI=] CASSANDRA Cry Troyans cry Lend me ten th... «'  Kyle Pakeman  Alex Clark: Andrew Wait: Dali... 16 Aug 2 -
] &9 Andrew Wat 123 AJAX Therstes THERSITES Agamemnon-o... ~  Brian Rudy Raid; Robert Rise: Susa... 16 Aug 21 Attach a serverto enable
D;:"i Andy Kort [ BOYSir rmy lord would " Susane Tyler Dalia; Tim Goodler; Kyle Pake.. 16 Aug 2 drag-and-drop injection of
[ Bian [T]24  PANDARUS Asses fools dotts chaff and ' Bran Fudy Raid: Robert Rise: Susa. .. 16 Aug 20 messages f;d fﬂ‘_l:“m‘fmm
IEET™ ()24 PANDARUS That's Hector that that ' Susane Tyler  Daia; Tim Goadler: Kyle Pake.. 16 Aug 21 Bechange, e
-[C159 John [C1E3  CRESSIDA Who were those went ' Maria Woods Tim Goodler; Robert Rise; Kyl... 16 Aug 21
Dg Juliet Capulet [C1E3 TROILUS Call here my varlet: ' Maria Woods Rabert Rise; Alex Clark: Andr. Q x2 16 Aug 20
7159 Kyle Pakerman [C1E3 In Troy there lies the ' Dala Romeo Mortague: Kyle Paker... 16 Aug 20
-5 Luise [T]E2 PUBLIUS What is your wil ' Richard Kyle Pakerman: Maria Woods... 16 Aug 21
|:|.=J Waria Woods [[JE KING We lost 2 jewel '  Susane Tyler  Andrew Wat: Dalia; Richard: ... 16 Aug 2
Drﬁ_ M.\chael [C]E  How now good fellow Wouldst " Susane Tyler Brian; Dalia; Maria Woods; Ri.. 16 Aug 2
059 Rechard [/ TITUS Come Marcus /' MaiaWoods  Anchew Wat; TmGooder, D.. (] x2  16Aug2l
-C19 Rober e 11 SATURNINUS Why lords what wrongs W AexClark Maria Woods; Michael; And . 16A1321
= %gm[:’l M:"‘E?;; )& CHIRON Demetrius here's the son +  Daia Romeo Mortague; Andy Kort . 16 Aug 2l
.D o Co:";;sr:m’ [ MESSENGER Worthy Andronicus o  AndrewWait  Fichard; Romeo Montague: .. [ x2  16Aug2l
| = FEER 16 Aug 21
: Eg g,:ze?mhems © [ Where: Al - | 1 selectarsttoms | ¢ 16 A2 -
] s
L-[FIE3 Inbox @2115) [T i ] ]
+[] 8l Joumal ()
[ Junk E-Mil @) TITUS Come Marcus =
Notes (0]
E‘L‘: hetes | (3]) Maria Woods Attachments: | Weakh of Nations-9571¢
3 Sent ems (28) Date: 16 Aug 2012, 18:32 3
-] A Tasks (0) To: Andrew Wait, Tim Goodler: Dalia; Rudy Shakespeare-1651.0¢
Dé Rudy Raid Raid Susana Tular lakhae Michsal Kils
-[C] &9 Susane Tyler v
7] £9 SystemMailboxd78d3a78c-3671-42c3a¢
5 TITUS. Come, Marcus, come; kinsmen, this is the way
Dd Tm Goodler Sir boy, let me see your archery;
Look ye draw home enough, and Yis there straight
Terss Astrea reliquit, -
< n 3 Preview | Properties
Completed | Selected: 0 nodes, 0 items |

Figure 7: The Exchange Granular Restore console

1 Selecting a folder will display the individual mail items inside it, on the pane to the right.
1 Selecting a mail item will preview its contents in the pane below it.

Exchange Granular Restore
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Using Search

The Search field is ideal when the location of a mail item or the number of items to restore is
unknown. When a keyword search is performed, a new tab with a browse tree will open containing
only the mailboxes, folders and mail items that match your search criteria.

The search word must be a whole word.

To perform a simple Search , enter the searchword into the field, click the search iconand the Search
tab will open in the console. This Seard tab will contain all items in the database that contains the
word you entered.

To perform an advanced Search , select the arrow by the Search field to display the advanced search
options. The Search infield will default to the entire database. To sarch inside specific mailboxes or
folders, select the Search infield and use the dialogue window to selectthe required containers.

The following search options are available

Has words searchesfor mail items that have words or phrases entered into the field.

Doesn't have searches for items that do not have words or phrases entered irto the field.
Has attachments will search for items with attachments.

From, will search for keywords inthe From:field.

To, will search for keywords in the To: field.

Subect, will search for keywords inthe Subject field.

Date range, can be used to set a specific date range. A beginning and end dates must be set.

=A =4 -4 4 -8 A -

File Options Help

Exchange Granular Restore

&= T @
1] Browse |Saard1 king * Entirs database Destination
EERY] S_earch king Type  Subject G| Haswords: king s Errren
7159 Alex Claric (57) . attached
-[C1 59 Andrew Wat (75) [C1Z  JAQUENETTA God bless the King KING What presert ha Doesn't have: -
159 Andy Kor 67) EIE KNG Lat fane thet o 7] Has attachments fitach a server o enable
&[] &3 Brian (55) [&] :J.l KING PHILIP So by a roaring tempest on the flood A whole. drag-and-drop injection of
1121 Calend: [T124  KING JOHN To ELINOR So From: messages and folders from
11 Calendar (7) - source mail store into live
153 Inbox (48) [C128  KING Chares | will play no mere To: Eie
-[C] £ Dalia (62) [C1Z KNG EDWARD Once more we =
159 John (64) [ The Beggar and the King Subject:
-[C] 59 Juliet Capulet (64) [ Inthe rsign of king
-[C] 55 Kyle Pakerman (62) [C1E2  Inthe anciert dominions of the king Date range: O to [Ehd
159 wise (58) [C12 - KING EDWARD Seize on the shamefacd
-] 59 Maria Woods (55) [/ KING HENRY Master Lisutenant now [ Search | [ Gear |
L1539 bichael (61) [C1E1 KING HENRY My lords ook
= £ KING HENRY See Buckingham Somerset Fobert Fise Romeo Mortague; Michael; B
D:i Richard (68) 0
E% xbed H‘MST_“(”] 62 [C15 KING HENRY How now What news Why com'st thou in Romeo Monta... John; Luise; Richard; Michael
Di.i’i Ru:yeoﬂa,:((:;ue [C1E2  KING HENRY I muse my Lord of Gloucester is not come Ti... Dalia Kyle Pakerman: Michael: Tim ...
Dg Susane Tyier (53) [T1E4  KING HENRY What tidings with our cousin Buckingham B... Andrew Wait Kyle Pakerman: Luise; Romeo... L 4
D:‘? Tim Goodler (64) [ KING HENRY For my part Romeo Monta... Rudy Raid; Andrew Wait; Mar...

[C1E1 KING HENRY Have you peustd the Susane Tyler  Brian; Dalia; Andrew Wait; Ru

[T KING HENRY We charge you on allegiance to oursef To Romeo Monta... Michael: Susane Tyler; Brian:

[l PISTOL Qui va la KING Maria Woods  Dalia; Robert Rise; Tim Good!

[C1E2  FRENCH KING Tis certain he hath pass'd the river Somme... Richard Brian

[14 KING HENRY How sits the Robert Rise Maria Woods: Luise: Brian: R... Q x

[T] =1 CLARENCE Deth the King call WARWICK

[C]1  KING Now lords if God doth give successful end

[C]i1  KING Go call the Earls of Sumey and of Wanwick; But ere t
b= Doug Am gentlemen to ams for | have thrown A brave def.
[T1E4  King My blood hath been too cold and

14 Lzer Where isthis king?- Tim Goodler  Brian

L T P P T RS . L PR YRR S

4 [} | +

Pageofl boM O 100

Richard Brian; Dalia; Andrew Wait; Ru..
Romeo Monta... John; Brian; Kyle Pakerman;
Susane Tyler  Juliet Capulet; Alex Clark; And
Kyle Pakerman  Alex Clark: Andrew Wait: Dali...
Dalia Brizn

R A O N N A S L AL G WS ST S S T

messages per page

Completed \ Selected: 0 nodes, 0 items

Figure 8: Exchange Granular Restore console - Search tab
If a search doesnot match any items, review your search parameters and run another search.

Once you have located the mail items that you want to restore, select them using the tick box. Once
you have selecied an item to restore, the restore type icons in the menu will become active.

Exchange Granular Restore
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Indexing Modes

Database indexing can be disabled or cancelled via the Options menu. If indexing is disabled, a
database search willnot be possible. Two indexing mode s are supported: Light and Full.

1 Light indexing (default): Limits the searchable information to the following fields: From, To, Subject,
Date range. A Tofield with a long recipients list and message bodies will not be indexed.

1 Full indexing: Thismode will take longer to index as it allows a search across the entire database.

Step 3 - Perform the restore

Once you have located the required mail items, there are three ways they can be restored using
Exchange Granular RestoreRestore tooriginal location, Restore toalternate location and Export to PST

Option 1: Restore to original location

=) This option will restore the selected mail items back into their respective mailboxes on the
’ original Exchange Server.

R

To perform the restore, follow the steps below:

a) Select the Restore to original location button .

A Restore to original locationwindow will open. The domain name of the serverrunning Exchange
will be automatically detected if you are on the same domain.

b) If no Exchange Server was detected, manually fill in theServer namefield and click Reconnect

It is possible to restore datato s o me one el s e d sExamdellnipersonatios Tordg this,
the current user credentials must have Exchange Impersonation access tdhe destination mailbox.

Server name:

Server not detected. The destination Exchange Server is
detected automatically using the
current Active Directory domain. If

Details: necessary, you can change the
server name, and attempt 2 manual

Source mailbox ‘egr user’ does not exist on the destination server: 19 folders will not be Restored. Reconnect.

Curment uzer: CORTEXIT

Mailbax GUID: f136feb4-Dbad-42ea-37e1-327bb 65 Sefd The current user must be a member

Pctive Directory connection: OK of the same domain as the target

Mailbox found in Active Directary: No agﬂ:gg: ‘Igr:w?sr;::tiz';{glld ha:?n

: i ilbox in Active Di Exchange Impersonation acces

Ermor message: Cannot find mailbox in Active Directary the destination mailboxes.

c) Select Restore to begin the restore process.

A progress window will be displayed during the restore. The window shows the number of folders,
messages ad errors. You can enable and disable the pogress window in the Options menu.

1 Therestore can be cancelledby clicking the Cancelrestorebutton.
1 The progress window can be reopened by clicking Progress baron the status panel.

1 Selected items will be copied into their original locations on the live Exchange Server. If
selected items cannot be matched to a destination mailbox, they will not be restored.

1 The destination Exchange Server is detected automatically using the current Active Directory
domain. If necessary, you can change the server name and attempt a reconnect.

Exchange Granular Restore
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Option 2: Restore to alternate location

7

To perform the restore, follow the steps below:

This option will restore the emails and mail items from the offline backup to a live Exchange
databasethat is different to the one they were backed up from .

a) Select the Connect t o Exchange Mailbox button.

The Connect to Exchange Mailboxoutton will open the connection dialog box , which is used to
provide the Exchange Servername and the authentication details (User logon) for a specific
mailbox on that server. This authentication process can be repeated for additional mailboxes.

The Restore toalternate location button will become active when a connection has been made.

Exchange Granular Restore
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Figure 9: Restore to alternate location & connection authentication

Enter the following details into the connection dialog box:

1 Server rame - Domain name Exchange Server or IP address
1 Mailbox user name - This will identify, authenticate and open the applicable mailbox.
1 Password The password for the applicable mailbox.

If Use current Windows credentialsis selected,the e x i st i nWjndaws masswosd will be used.

If Exchange Impersonationis selected, enter the SMTP addressof the mailbox that you want to
connect to. Exchange impersonation must also be configured on the Exchange Server

Once the connection has been made, the mailbox you have authenticated to will appear as a
mailbox tree in a new pane called Connected Mailboxes You can open a preview pane for the
destination mailbox tree by selecting the Show item list and previewicon (CTL+R), to the right of
the Connected Mailboxespane.

b) Restore mail items to an alternate location

There are two ways to restore mail items to the alternate location: drag and drop and the Restore
to alternate location button .

Exchange Granular Restore >
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Drag and drop

Drag and drop mail items from the EDB database backup, into the live Exchange mailbox that you

have connected to.

1 The hierarchy of the data being dragged will be recreated inside the destination folder.

1 You cancreate a new folder in the live mailbox by right clicking the mailbox or a folder. Note,

you cannot delete or rename a folder once it has been created.

File Options Help

Exchange Granular Restore
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Restore to alternate location

Click the check-box next to items that you want to restore and select the Restore to dternate
location button. A dialog box will open and allow you to select a destination folder on one of the

button

connected mailboxes. Make your destination selection and select OK to begin the restore

1 The data hierarchy will be restored automatically.
1 The root of hierarchy is the closest common parent item.

Source mail item s and destination folder compatibility

Not all types of mail items can be restore to all types of destinations folders. The following table

shows the compatibility matrix of source mail item types and destination directories.

Item type *Mail folder Journal s Notes Contacts Calendar Tasks
Message Y Y Y Y
Journal Y Y Y Y Y
Sticky Note Y Y Y Y Y Y
Contact N N N Y N N
Calendar N N N N Y N
Task N N N N N Y

* The Mail folder includes Deleted Items, Drafts, Inbox, Junk, Outbox and Sent.

If some or all of the selected items cannot be restored (using drag and drop or clicking the Restore

to alternate location button) to the destination folder, then an error message will be displayed.

© Cortex I.T. 2001-2015
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Option 3: Export to PST

Export to PST will save your selected data ina PST file which can be opened by outlook to

o o
access the mail items

’ .PST

To perform the export, follow the steps below:

a) Confirm the Personal Storage Table (PST)format
You canchoose Unicode or ANSlencoding for the PSToutput file using the Options menu.

The Exchange GranulaRestoreconsole exports each mailbox into a separate .pst file named:
Restore NNN <Mai l box Name>[ VYV Yhg curreptgecayery session identifildkNN i s
and VVVis the volume number, in case the PSTiile has to be written in more than one volume.

With large exports, there can be more than one PSTfile. Additional files are created automatically
when the file size limit is reached. The size limit depends on the output file encoding.

1 For ANSI PST filesthe sizelimitis 1 GB

1 For Unicode PST files, the size limit isLlO GB

1 A maximum of 15,000 messages can berestored into the PSTfile.
1 When this limit is reached, an additional PST fileis created.

b) Selectthe, Exportto PST button

This button will become active once the mail items have been selected

c) Select the destination.

You will be asked to select a folder or create a new folder. After selecting the new or existing
folder, the export will begin.

You will be shown a progress window during the export. The window shows the number of saved
mailboxes, folders and messages. The exportan be cancelled by clicking the Stop Exportbutton. If
you close the progress window, it can be openedagainby c¢cl i cking the status pan

Selected data will be saved into pst file(s). To start the export select the
destination folder or create a new one and click OK. The export process will start

immediatehy.
£ Recycle Bin o
> . DOCS
4 | EGR
> ) EGR il
> EGR-wireframe E
> mail i
. mail itemns restored
> . NEW HELP -
PST Encoding: | Unicode -

o J o |

The items selected (even if you only lected one item) will be exported as a PST file.

Exchange Granular Restore 4
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d) Open the exported mail items in Outlook

1. Click File> Open and choose Open Outlook Data File
2. Browse to the PST file that was exported, then select it and clickOK.
3. The PST file will appear in Outlook asa container.

Figure 10: Opening an exported PST file in outlook

e) Restore the exported items to the Exchange Server.

Items extracted from an offline Exchange mail store can be restored to a live server. Make sure you
have Microsoft Outlook and access to the mailboxthat you want to restore the mail items into.

1. Open the PSTiile that contains the exported mail items.

2. Open the mailbox that you need to import the data into.

3. Drag-and-drop the item them back into the ir original folde rs. They will be automatically
synchronized with the live Exchange Server database.

Figure 11: Restoring a PST file to an Exchange Server.

Exchange Granular Restore 5
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