Rysnc backup not working - incompatible version of cygwin

This forum is no longer monitored by the BackupAssist support team, but is available to the public to use for assistance with technical issues relating to BackupAssist v5.x.x.

Moderators: casey.burns, Stuart, michael.jones, gsohal, Mike D

Rysnc backup not working - incompatible version of cygwin

Postby stupot1397 » Mon Jul 16, 2012 11:00 pm

Hi,

I am recently been having trouble with using rsync to backup an external server. We are using backupassist 5.4.8, on Windows Server 2008.

The Job appears to start but does not run:

7 [main] rsync 3448 C:\ProgramData\BackupAssist v5\temp\Rsync\rsync.exe: *** fatal error - system shared memory version mismatch detected - 0xFF0B00D2/0xFF0B00C8.
This problem is probably due to using incompatible versions of the cygwin DLL.
and delete all but the most recent version. The most recent version *should*
reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution. Rebooting is also suggested if you
are unable to find another cygwin DLL.

This has been working fine but I can no longer do an rsync backup. Unfortunately it caused the backup jobs to hang so I had no notification of a problem.

I have tried uninstalling and reinstalling but to no effect.

I hope someone can help.

Thanks
stupot1397
User
 
Posts: 1
Joined: Mon Jul 16, 2012 10:56 pm

Re: Rysnc backup not working - incompatible version of cygwi

Postby Stuart » Mon Jul 23, 2012 1:30 pm

Hi there,

It's Stuart here from the BackupAssist team, thanks for posting on our forum.

Sorry to hear that you're having these issues with your Rsync backup.

When you say you've re-installed, what exactly did you re-install? I ask this as cygwin is completely different to BackupAssist and uninstalling BackupAssist wouldn't have any impact on this at all.
You may need to download and install the latest version of cygwin from http://www.cygwin.com/ onto the Rsync destination you're using for backups to be able to resolve this issue.

Hopefully this suggestion puts you onto the right track in gaining a resolution.
Stuart Edwards
BackupAssist Support

*Have you tried restoring from your backups lately?*
Stuart
Cortex I.T.
 
Posts: 998
Joined: Tue Sep 02, 2008 2:25 pm


Return to Technical Support v5

Who is online

Users browsing this forum: No registered users and 10 guests

cron