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Introduction 

This whitepaper will outline the setup of four NAS devices that will provide BackupAssist with an Rsync data host. 

The data host will be configured so BackupAssist for Rsync can connect and upload your data via either an 

Rsync daemon or Rsync via an SSH tunnel to the NAS device. 

For the purposes of a turnkey Internet backup solution, we strongly recommend the QNAP for two reasons: 

first, it is the only one that supports secure Rsync – that is, running Rsync over SSH (the same encryption 

technology as https); and second, it is very easy to setup and configure, whereas other devices require more 

effort. 

None of these devices are endorsed by BackupAssist, they are only devices that we have tested with 

BackupAssist for Rsync and are capable of accepting an Rsync connection from BackupAssist for the purpose of 

data transfer.  

Hardware Setup Instructions 

QNAP TS-209 

This setup guide begins with a QNAP TS-209 with factory default settings. 

1) Begin by setting up your NAS as per the „out-of-the-box‟ instruction. This include adding disks, powering 

the device up and connecting it to your network. 

2) Insert the setup disk into a workstation on the same network as the QNAP, install and run the QNAP 

Finder. 

3) Once QNAP finder has located your QNAP click on the entry in the table, then click „configure‟ (see 

below). This will begin the QNAP setup wizard that will guide you through setting up the device. During 

the wizard you will be required to change the Admin account password as well as set up the network 

interface. It is important during these steps you take note of the password and IP address for the QNAP. 
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4) After you complete the setup wizard your default internet browser will be launched and the below page 

will load. Click “Administration” and enter the administrator account details. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5) Once at the main page, click „Remote replication‟ under the „System tools‟ heading. Once the page 

loads, check the tick box marked “Allow remote Rsync server to back up data to NAS”, then click “ok”. 

Close the window to log out. 
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You should now configure the BackupAssist client to use your NAS data host. Install BackupAssist v5.1 or later. 

You will have a free 30 day trial, but beyond this trial period, you will need to purchase a licence for 

“BackupAssist for Rsync” to continue using it. 

 

1. Once BackupAssist is installed you will need to create a new BackupAssist backup job.  

i. Launch the BackupAssist console and choose File > New backup job from the top menu. 

ii. Select Rsync as your Backup type and click Next (see screenshot below). 

 

iii. In the Rsync Server options section (see screenshot below), complete the following: 

a. Enter your Rsync server name (or IP address), and choose “Rsync over SSH”. This option 

ensures that your data is encrypted over the wire. 

b. Under “Path on server”, type in the path to your backup directory. For the QNAP you will want 

to write you backup data to a sub directory in the /share/ path i.e. /share/backups/ for ease of 

access.  

Note: It is best to use a new, empty directory for this path. The parent directory must exist, 

but the sub directory will be created when the job is first run, i.e. /parent/sub_directory/. 

c. Enter the account name “admin” as your username  

d. Click „Register with server…‟ You will be prompted to enter your password, and, once entered, 

BackupAssist will create a public/private key pair to authenticate you to the data host. This will 

be the only time you need to enter your password. If successful, a message will appear to the 

right of the „Register with server...‟ button. 

e. Click the „Test connection…‟ button to test communication with the Rsync server. 

 

To gain access to you data, you can access the /share/ directory in one of two ways: 

As a network share: Simple type \\[Server IP]\ into (start > run) and you will be presented with the contents of 

the /share/ directory/ 

Via FTP: By default the QNAP runs an FTP server on port 21. To access this simple go to your web browser and 

type into the address bar ftp://[SERVER IP]/. You will be prompted for the Admin account details before you are 

able to access your data.  



WHITEPAPER 
Rsync-enabled NAS Hardware Compatibility List 

6 

 

Netgear ReadyNas NV+ 

Note: Since conducting our testing, Netgear have released the Pro Business, NVX and 2100 models which 

our customers tell us support Rsync over SSH. Some of the following steps may not be applicable to these 

models. 

This setup guide begins with a ReadyNas NV+ with the factory default settings. 

1. Start by setting up your NAS so that you are able to access the web-control panel. 

2. Once you have the device RAID operational, open a browser window and navigate to https://[netgear 

IP]/admin and log in using the admin account. 

Note: the IP of your NAS can be found by looking at the small display located at the bottom of the NAS 

device. If this display is blank, briefly press the power button to activate it. 

3. From the ReadyNas control panel click „Setup Wizard‟ to begin the setup process. During this process 

there are a number of key steps required to allow BackupAssist to connect to the ReadyNas via Rsync, 

which are outlined below. Some of the setup, however, will be specific to your own network and is not 

covered in the scope of this whitepaper. 

Time date region: User set 

Email contact settings: User set 

IP config settings: User set – you need to ensure, however, that this subnet is reachable by your 

BackupAssist machine. 

Gateway settings: User set – these need to be setup correctly in order for the NAS to have access to the 

Internet so as to make use of Rsync over a WAN.  

Password creation: The password you create in this step will be used by BackupAssist to connect to 

Rsync that will be running on this NAS. 

File sharing settings: Depending on how access to the internet is configured on your network you may 

need to alter these settings. 

Protocols: Here you will need to enable the Rsync protocol on the ReadyNas. To do this, simply tick the 

box marked “Rsync, a popular incremental backup protocol used in Unix and Linux environments.” 

Streaming services: User set 

Add-ons: User set 

Shares on RAID Volumes: No changes need to be made on this window. 

Add shares: You will need to create a new share for your Rsync data to be stored. In this example we 

have created a share called “rsyncdata” with no size limit (data quota).  
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USB Printers: User set 

Registration: User set 

 

4. Once the wizard has been completed, click the „Advanced Control‟ button, then expand the “Shares” 

menu and click “share listing” to access the view below. 

 

5. Under the “Rsync” column click the document icon that corresponds to you Rsync data share (in this 

case, “rsyncdata”) to access the Rsync connection options. 

6. Enter the username and password that BackupAssist will use to connect to your Rsync server. 
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i. You will also need to change the following settings on this screen: 

Default Access = Read/Write 

Enable password protection = enabled 

ii. Apply these settings then log out of the console. 

You are now ready to link the BackupAssist console to your NetGear ReadyNAS. 

7. To configure the BackupAssist client to use your Windows data host first install BackupAssist v5.1 or later. 

You will have a free 30 day trial, but beyond this trial period, you will need to purchase a licence for 

“BackupAssist for Rsync” to continue using it. 

8. Once BackupAssist is installed you will need to create a new BackupAssist backup job: 

i. Launch the BackupAssist console and choose File > New backup job from the top menu. 

ii. Select Rsync as your Backup type and click Next (see screenshot below) 
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iii. Enter in your Rsync server name (or IP address), and choose “Rsync Daemon”. This option will not 

encrypt your data. 

iv. Under “Path on server”, type in “rsyncdata” 

v. Then enter in the Username: Admin and Password for this account to access the ReadyNAS. In our 

case Backups and the appropriate password. 

vi. Click the “Test connection…” button to test communication with the Rsync server 

 

 

 

Drobo rev1 

This setup guide begins with Drobo rev1 with the factory default settings. 

1. Begin by setting up your Drobo as per the manufacturer‟s instructions, ensuring that you have enabled 

your Drobo to run DroboApps by completing the following:  

i. From the Drobo Dashboard open "Advanced Controls" and choose the "Tools" tab 

ii. Click "Setup" from the DroboShare section and select the "DroboApps" tab  

iii. Check "Enable DroboApps"  

2. You will then need to download the Drobo Rsync client and place the downloaded file in the DroboApps 

folder of your Drobo. Client available from http://www.drobo.com/droboapps/downloads/index.php?id=12 

3. To finish the installation of Rsync on your Drobo you will need to reboot it. 

4. After you Drobo has restarted use a file browser to navigate to the DroboApps/Rsync/ directory and, using 

a plain text editor (such as notepad or wordpad), open the rsyncd.conf file. Under the [Drobo0] entry 

replace all entries with the following and save the file: 

path = /mnt/DroboShares/Drobo 

comment = Drobo Share 

read only = false 

Note: we assume here that your main Drobo share is called "Drobo", which is the default name given by 

the Drobo client software. 

You are now ready to link the BackupAssist console to your Drobo device. 

http://www.drobo.com/droboapps/downloads/index.php?id=12
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5. To configure the BackupAssist client to use your NAS data host, first install BackupAssist v5.1 or later. 

You will have a free 30 day trial, but beyond this trial period, you will need to purchase a licence for 

“BackupAssist for Rsync” to continue using it. 

6. Once BackupAssist is installed you will need to create a new BackupAssist backup job.  

i. Launch the BackupAssist console and choose File > New backup job from the drop-down menu. 

ii. Select Rsync from job type choices and then click Next (see screenshot below) 

 
 

iii. Enter in your Rsync server name (or IP address), and choose “Rsync Daemon”. This option will not 

encrypt your data. 

iv. Under “Path on server”, type in “Drobo0” 

v. Then enter in the Username: Admin and Password for this account to access the Drobo.  

vi. Click the “Test connection…” button to test communication with the Rsync server. 

(see screenshot below) 

 

Synology Disk Station DS 408 

This setup guide begins with a Synology Disk Station with the factory default settings. 

1. Being by setting up your Synology using the quick setup guide, making sure to specify a password for the 

'Admin' account when prompted. 
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2. Once the setup has been completed, use the Synology Assistant to access the HTTP management 

console. 

3. From your Synology's management console there are a number of things we need to setup: 

i. Creating a partition: 

a. Click storage > volume from the Synology management console 

b. Then choose Create from the volume management window and follow the wizard (please note 

for this example we are using volume1 for all of our storage, you can change this as you see fit) 

 
ii. Enabling Terminal Services: 

a. To do this click Network services > Terminal from the Synology management console and 

enable the checkbox marked “Enable SSH service” 

 

iii. Enabling Network Backup (Rsync) 
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a. To do this click Backup > Network Backup Service from the Synology management console 

and enable the checkbox marked “Enable network backup service” 

 

4. Take note of the IP address of the Synology (found under Information > Status) 

5. Using an SSH Terminal Service provider such as Putty (URL for putty) log into an SSH session on your 

Synology, using: 

i. The IP address noted during step four. 

ii. The user name: root  

iii. The password of your Admin Account.  

6. Once you have logged into the terminal you will need to modify the Rsync config file to allow 

BackupAssist to connect to the Synology and place the data in the correct directory. You will also need to 

modify the home directory of your Admin user to the backup directory. 

i. From the terminal enter the following: 

vi /etc/passwd 

ii. Then using the arrow keys locate the following line: 

admin:x:1024:100:System default user/volume1/@database/:/bin/sh 

iii. Using the „x‟ key to delete characters make the line as follows: 

admin:x:1024:100:System default user/volume1/:/bin/sh 

iv. the press „shift‟ +‟z‟ twice to save and exit. 

7. You will now need to modify your Rsync config file to point it to the backup directory.  

i. Enter the following: 

vi /etc/rsyncd.conf 

ii. Then press „i‟ to edit the file in text mode, and modify the line under [Netbackup] to be the following 
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Path = /volume1/NetBackup/ 

iii. Press „esc‟ then „shift‟ +‟z‟ twice to save and exit. 

8. You now need to stop and start the Rsync service on the Synology to affect the changes you have made: 

i. Enter the following: 

ps aux 

This will present you with a list similar to that shown below. You will need to kill the process using 

the process ID; in this case it is 5521.  

 

ii. To kill this process, locate it in the list and with your process ID type the following: 

kill 5521 

Where 5521 is your Rsync process ID 

iii. Then you will need to restart it with the following line 

/usr/syno/bin/rsync  --daemon 

iv. Then type: 

Exit 

You are now ready to link the BackupAssist console to your Synology NAS device. 

9. To configure the BackupAssist client to use your NAS data host first install BackupAssist v5.1 or later. 

You will have a free 30 day trial, but beyond this trial period, you will need to purchase a licence for 

“BackupAssist for Rsync” to continue using it. 

10. Once BackupAssist is installed you will need to create a new BackupAssist backup job.  

i. Launch the BackupAssist console and choose File > New backup job from the drop-down menu. 

ii. Select Rsync as the Backup type and then click Next (see screenshot below). 
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iii. Enter in your Rsync server name (or IP address), and choose “Rsync Daemon”. This option will not 

encrypt your data. 

iv. Under “Path on server”, type in “NetBackup” 

v. Then enter in the Username: Admin and Password for this account to access the Synology.  

vi. Click the “Test connection…” button to test communication with the Rsync server. 

(see screenshot below) 
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Troubleshooting and Support 

Appendix 

Data host – the server that has been set up to host backup data 

Client – the machine that BackupAssist is installed on, that sends data to the data host 

SSH Authentication – For SSH communication, we use a public / private key method of authentication meaning 

that you will only be asked for your password once (when registering with the server), and your public key will be 

uploaded to the server, enabling BackupAssist to log into the server in the future in a secure, password-less 

manner.  For more information on public / private key authentication, visit the following Wikipedia article. 

Wikipedia Public Key Cryptography 

Daemon Authentication – For Daemon mode, your password is stored in encrypted format by BackupAssist 

and provided every time the backup runs. When running in Daemon mode, traffic will be unencrypted. For this 

reason, we recommend that you only use this closed network environments, such as LANs or WANs connected 

by a secure VPN. Note that VPNs inherently encrypt communication between nodes, so using Rsync in Daemon 

mode over a VPN is still secure. 

Troubleshooting 

Test connection failed: Ensure that you are able to ping your Rsync server from your BackupAssist server and 

you have opened up the appropriate ports on your firewall.  

Register with server failed: Ensure that you have the correct username and password as setup on your Rsync 

server. 

When using Rsync over SSH you are repeatedly asked for your password during the ‘register’ phase: 

Ensure that you have removed the „Deny local logon‟ entry for your local machine, or in domain policy. 

Support details 

Thank you for taking the time to view this Whitepaper. If you have any enquiry about BackupAssist or the Internet 

Backup add-on please contact us via email: support@backupassist.com   

 

http://en.wikipedia.org/wiki/Public-key_cryptography
mailto:support@backupassist.com

